打印程序正常安装后,用户在报表访问页面中点击“打印”、“打印预览”,没有任何反应。
问题现象:
1、在浏览器中按F12或通过更多工具/开发者工具发现控制台(Console)中,显示网络请求错误,如下图所示:
可能原因:
原因1、打印服务没有启动
按照对应操作系统下的启动方式,确保客户端打印服务已经启动。
原因2、高版本的浏览器阻止了
谷歌浏览器
原因:谷歌浏览器在94+版本,增设了一项安全机制“Block insecure private network requests”:阻止不安全、本地网络请求
解决方法:
步骤一、打开新的网页,浏览器输入:chrome://flags/#block-insecure-private-network-requests
步骤二、将“Block insecure private network requests”设置项,由Default修改为Disabled,如下图:
谷歌浏览器升级可能会重置该安全机制。如果前面关闭过该安全配置,后续使用打印时却再次提示服务未启动,可以重新关闭该安全配置。
火狐浏览器
原因:火狐浏览器阻止混合活动内容
解决方法:
步骤一、打开火狐浏览器新标签页,在地址栏输入 about:config,进入配置页面;
步骤二、在配置搜索栏搜索 security.mixed_content.block_active_content,定位到属性列表行,双击即可修改属性值为false 。
360安全浏览器
解决方法:
步骤一、打开新的网页,浏览器输入:se://flags/#block-insecure-private-network-requests
步骤二、“Block insecure private network requests”设置项,由Default修改为Disabled
作者:柳杨 创建时间:2025-05-23 15:03
最后编辑:柳杨 更新时间:2025-06-05 14:14
最后编辑:柳杨 更新时间:2025-06-05 14:14
